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Introduction

PeenSolver Pro™ is the latest saturation curve solver from Electronics Inc. This program includes many features seen
in other curve solvers with new features added after reviewing customer feedback. The manual will provide the
necessary information to operate the program and it should be read carefully to ensure all procedures are followed
and to take advantage of the program’s features.

Installation
e Download from www.electronics-inc.com
e Run file named “PeenSolverPro-Installer.X.X.X”

e Follow on-screen instructions

#5 PeenSolver Pro - X

Welcome to the PeenSolver Pro Setup Wizard -l

The installer will guide you through the steps required to install PeenSolver Pro on your computer.

WARNING: This computer program is protected by copyright law and intemational treaties.
Unauthorized duplication or distribution of this program, or any portion of it, may result in severe civil
or criminal penalties, and will be prosecuted to the maximum extent possible under the law.

Back Cancel

e  Click “Next >”

ﬁl PeenSolver Pro - X

License Agreement [

Please take a moment to read the license agreement now. If you accept the terms below, click "'l
Agree", then "Next". Otherwise click "Cancel".

PLEASE READ THIS END USER LICENSE AGREEMENT ~
(“EULA™) CAREFULLY BEFORE USING SOFTWARE FROM
ELECTRONICS, INC. (“THE LICENSOR™). BY USING LICENSOR’S
SOFTWARE. YOU SIGNIFY YOUR ASSENT TO AND
ACCEPTANCE OF THIS END USER LICENSE AGREEMENT AND
ACKNOWLEDGE THAT YOU HAVE READ AND UNDERSTAND
THE TERMS AS STATED HEREIN. INDIVIDUALS ACTING ON
BEHALF OF AN ENTITY REPRESENT THAT THEY HAVE THE

v

O | Do Not Agree @ | Agree

Next > Cancel

e Agree to the license agreement and click “Next >”

Electronics Inc. » (574) 256-5001 » www.electronics-inc.com I 3



ﬂ PeenSolver Pro

Select Installation Folder

The installer will install PeenSolver Pro to the following folder.

Taoinstall in this folder, click "Next". To install to a different folder, enter it below or click "Browse".

Folder:
C:\Program Files (x86)\Electronics Inc\PeenSolver Pro\ Browse...
Disk Cost...
Install PeenSolver Pro for yourself, or for anyone who uses this computer:
(® Everyone
O Just me
< Back Cancel
o  Click “Next >”
#5 PeenSolver Pro . X
Confirm Installation [
The installer is ready to install PeenSolver Pro on your computer.
Click "Next" to start the installation.
< Back Cancel
o  Click “Next >”
ﬁ PeenSolver Pro - X
Installation Complete [
PeenSolver Pro has been successfully installed.
Click "Close" to exit.
< Back Cance

e  (Click “Close” when complete
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Calculating Saturation Curve

Configuring Test Settings
Open PeenSolver Pro™ by double clicking on desktop app

Once open, navigate to File->New
Settings window will pop up
Configure test setting as desired

Click “Continue” once settings are filled

Universal Settings

Operator: Name of person who completed the test
Date: Date testing was completed
Comments: Any additional information not covered by settings
Strip Type (Default: A): Allows for user to select between “A”, “N”, and “C” Almen Strips.
Unit System (Default: Imperial): Toggles between Imperial and Sl units and units will be reflected on the
graph. Units will be displayed in inches and millimeters.
Curve Type (Default: Auto (2PF)): Determines the equation used to draw saturation curve. There are five
(5) possible modes to choose from:

1) Auto (2PF): Determines the equation based on the number of strips. If four (4) strips are entered

the 2PF equation is used. If five (5) or more are entered, the 3EXP equation is used.

2) Auto (2EXP): Same functionality as Auto-2PF but uses 2EXP for four strips rather than 2PF

3) 2PF:Uses 2PF equation regardless of strip count

4) 2EXP:Uses 2EXP equation regardless of strip count

5) 3EXP: Uses 3EXP equation regardless of strip count
Control Type (Default: Time): Changes the X unit on graph and input table. Other options include Speed
and Feed Rate.
Units (Default: s): Time unit used in for testing. Must be “s” for seconds or “m” for minutes.

Curve Verification Check Box (Default: on): Notifies user that a measured arc height is outside of a given

range of the calculated curve. Turning off this feature will hide program notifications of an error.

Curve Error (Default: 5%): Threshold for the program to notify that a calculated point has deviated from a

measured point.

Intensity Limits: User determined values for intensity limits. These values are used to display limits

graphically on the saturation curve.

Test Verification Limit (Default: +/-0.0015): Limit for test verification strips to be off from the original test.

If limit is exceeded, the user will be notified that the test verification value is outside the desired range.

Auto Export Verification (Default: On): CSV file is automatically generated or updated every time a new

verification is saved. Note: Data will be saved in .peen file regardless if data is exported to .CSV at each

verification. Turning this back on will export all data that was not exported in previous tests.
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6

Conventional Peening

ED Process Settings

Operator: ’Ken Derucki

X

Date: [10/14/2022 [E~

Comments: | Testing

Peening Method  Strip Type Unit System Curve Type Control Type  Units
Conventional v |[A v||Imperial (n) | AUTO (EXP2P) v Tme v [s |
Shot Type Air Pressure Flow Rate Speed (RPM)
5230 | [65 psi |10 Ib/min | [10rpm |
Blast Angle MNozzle Size Nozzle Distance
190 deg | [o.25" || |
Bl e Intensity Limit 1 (in)  Intensity Limit 2 (in)  Verification Limits (in)
Verification Upper 0.0088 = 0.009d = 0.0015 =
Error (%) 5.00 =| Lower 0.0060 = 0.0065 = -0.0015 =
Export Verification
oK el Data Automatically

o Shot Type: The type of media used in testing

e  AirPressure: Air pressure at the nozzle used in test

e  Flow Setting: Flow rate of media

e  RPM: Speed of table or fixture used to hold Almen Strips
e Blast Angle: Angle nozzle is to blasting surface

¢ Nozzle Diameter: Inner diameter of nozzle

e Height Above Strip: Distance from nozzle to strip

I Electronics Inc. ® (574) 256-5001 » www.electronics-inc.com




& Process Settings

*

Operator: ‘ Ken Derucki

Date: |10/14/2022 [E~

Comments: | Testing

Peening Method  Strip Type

Unit System Curve Type Control Type  Units
Rotary Flapper v | |A v| [imperial in) v [AUTO EXP2P) | [Time  ~
Speed (RPM) Conversion Factor
|5500 AMS v
EnableiEimne Intensity Limit 1 (in)  Intensity Limit 2 (in)  Verification Limits (in)
Verification Upper: 0.0023 = 0.00%0 = 0.0015 =
Error (%6): 5.00 Lower: 0.0060 = 0.0065 = -0.0015 =
Export Verification
oK Cancel Data Automatically

Rotary Flapper Peening

e RPM: Speed of rotary flapper device when testing

in this box.

The following page shows a screenshot of PeenSolver Pro™ after the “Continue” button is pressed. With the test
settings configured, it is now time to enter data. It is also possible to skip entering in settings and go straight to
entering data. Settings can be configured later by going to Edit-> Process Settings. The same window will pop up as

when File->New is selected.

Flapper Conversion: Conversion of a flapper peened strip to a conventional strip due to differing Almen
holders. For this test, if “A” strip is selected in “Strip Type”, either “0.77” or “AMS” can be selected.
PeenSolver Pro will also convert for “N” strips. Note: Selecting “N” strip will override any conversion entered
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PeenSolver Pro (Untitled)

Process Settings:

File Edit Help
El . ' Get in Touch... Phone: 574-256-5001
ectronics Inc. """ s inisgand
. 56790 Magnetic Dr Fax: 574-256-5222
Shot Peen,ng COﬂtml Mishawaka, IN USA 46545 Email: info@electronics-inc.com
Location 1
Name: ILocation 1 | Saturation Point
Arc Height (in)
Add Add Strip  Pre-Bow (in) Time (s) Arc Height (in) |:|
Location Strip > Te—
& [ ]
Delete Remove 3
Lecation Strip 4
Enter at least four arc
heights to determine
Eoree saturation.
Update
Graph Options .
(O Display All Locations Saturation Curve
(O Display Current Only o
Location 1 7
£
E
.% 50
Show Saturation -
v i
/| Show Limits =
O T T T | T 5 T I T B T | T T | T T T
0 20 40 60 80 100

File Location:

Time (s)

Operator: Ken Derucki
Date: Oct 4, 2022
Comments: Testing
Peening Method: Conventional
Strip Type: A

Curve Type: AUTO (EXP2P)
Unit System: Imperial (in)
Control Type: Time
Control Units: s

Shot Type: 5230

Air Pressure: 65

Flow Rate: 10 Ib/min
Speed: 10 rpm

Blasting Angle: 90 deg
Nozzle Size: 0.25"

Nozzle Distance: 8"

Last Verification Test Results:
Operator: |
Timestamp: |
Time: I
Location Target Measured

Perform New Verification Test

8 I Electroni

Saturation Curve Generation

e Enter Data: To enter data, simply select the cell you wish to change and enter the desired data. The default
settings give room for four (4) strips to be entered. This can be changed by clicking “Add Strip” or “Delete
Strip”, to the left of the table. The minimum number of strips needed is four (4) and the most that can be
entered is seven (7). Do not leave rows blank. If a row is not being used, delete the row. To add another
strip location, select “Add Location” and another tab will open to input data.

e Once at least four (4) strips are entered, the program will automatically plot the data and update as data
is changed.

csinc. » (574) 256-5001 » www.electronics-inc.com




& PeenSolver Pro (Testing)

File Edit

Help

Electronics Inc.
Shot Peening Control

Get in Touch...

Electronics Inc.
56790 Magnetic Dr.
Mishawaka, IN USA 46545

Phone: 574-256-5001
Toll Free: 800-832-5653
Fax: 574-256-5222

Email: info@electronics-inc.com

Process Settings:

Operator: Ken Derucki

Date: Oct 4, 2022

Comments: Testing

Peening Method: Conventional

Strip Type: A
Top Side Curve Type: AUTO (EXP2P)
Unit System: Imperial (in)
Name: |Top Saturation Point gon:ro: ‘Igp;: Time
Arc Height (in) chielUALE &
. g - . . Shot Type: 5230
Add Add Strip Pre-Bow (in) Time (s) Arc Height (in) 0.0076 RS
- - Flow Rate: 10 Ib/min
Location Strip » h 2 0.0069 r— phosiplgr g
2 4 0.0078 Blasting Angle: 90 deg
28 Nozzle Size: 0.25"
Delete Remove = 2 0.0084 MNozzle Distance: 8"
Location Strip 4 16 0.0086
Last Verification Test Results:
Operator: | Dave Barkley
F
Update Timestamp: | 10/4/2022 9:52 AM
Time: | 3
Graph Options Saturation Curve Location Target Measured
(O Display All Locations Top 0.0077 0.0078
(O Display Current Only | Side 0.0097 0.0099
-
0.01
pe
*
2 x
£
£ | / ’
5 i 4
L7
[~] Show Saturation § 0.005
[ Show Limits - |
0 T | B T | T T T T I T T T I
0 5 10 15
Time (s)

File Location:

Ci\Users\kderucki\Desktop\Testing.peen

Perform New Verification Test

Saturation Point

e Intensity: Intensity result of the selected strip location.
o  T:Tresult of the selected strip location.
e  Errors: Errors in the selected strip. Errors can be of two (2) types:

Post Calculation Options

Electronics Inc. ® (574) 256-5001 ¢ www.electronics-inc.com I 9




o Longest Peened Time is Shorter Than 2T

Saturation Point
Arc Height (in)

0.0129

Time (m)

18 mins 6.12 secs

Error: Curve is
invalid. Longest
peened time 15
cshorter than 2T.

o Shortest Peened Time is Longer Than T

Saturation Point
Arc Height (in)

0.007

Time (m)

4 mins 0 secs

Warning: Type 2
Curve - Shortest
peened time is
longer than T.
Intensity changed to
first peened strip’s
arc height.

Graph Options
e Display All Locations: Displays all locations in the program. Graphs can be toggled by selecting the highlighted
locations

e Display Current Only: Displays only the selected location

e  Show Saturation: Toggles the saturation point for the selected location tab

e  Show Limits: Toggles user defined limits set in process settings page
PSP also allows the user to trace the curve and display the corresponding point. Left click the desired curve and hold
down while dragging along the curve.
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Curve Verification

e Hoveronany entered arc height to display the error from the calculated curve.
e Thisfeature can also be used for the entire curve. Right click on the “Arc Heights” cell on a given test to find

the average error for all points.
e  Figure below shows what a curve verification error looks like.

Mie |l ICIHIIL llIII‘l
Time (s) Arc Height (in) 0.0075
2 0.005 ] Time (s)
4 432
g o/ Curve Error: 9.22%
16 0.0081

4 0.008 @ 4,656

8 0009 @
16 0.0081 @

Changing Test Settings After Curve Generation

If settings need to be changed after calculating or if settings were not entered into the program, they can be entered
after the curves are calculated. Navigate to Edit-> Process Settings and the test settings window will come up.

PeenSolver Pro also can clear a given test or clear all data. To do this, navigate to Edit and either Clear Current Test
or Clear All Tests. Clear Current test will clear whatever location tab is selected.

Electronics Inc. » (574) 256-5001 » www.electronics-inc.com I 11



Saving/Loading Data

Saving Data

To save peening data, navigate to File->Save or Save As. If this is the first time saving, PeenSolver Pro™ will prompt
the user to name and select a file location for the data. This will produce a .peen file. This contains all peening data
and the verification data.

Note: Testing Verification will involve creating another file that will log verification values for future reference. This
will be covered in the Verification Section.

Loading Data

If it is desired to reopen a saved test after closing PeenSolver Pro this can be easily done by navigating to File->Open
and selecting the desired .peen file. PeenSolver Pro will automatically calculate the saturation curve when the data
file is open. If changes are made to the data set or test settings, the test will need to be resaved. It is also possible to
automatically open PeenSolver Pro by double clicking a .peen file.

Verification

& Perform Verification Test >

Operator: ‘Dave Barkley |

Time @ Saturation (m): | 5 mins 28.62 secs |
Verification Test Time (m): ‘ 3 E‘ mins ‘ 0.00 E‘ secs

Location Target (in) Measzured (in)
Test 1 0.0064 0.0064
Test 2 0.0038 0.0035 D]
Test 3 0.0079 0.0081
Test 4 0.0054 0.0031

Once the desired curves are calculated, the largest T value from the data should appear in the “Time @ Saturation”
box. The time values used for the test can be set by “Verification Test Time”. Arc heights at the time for each test
will appear in the Target boxes. The user can then enter test verification data in the Measured boxes. If this entered
value is outside the limit set for test verification, a red “X” will appear, notifying the user that there has been a
problem.

With the test verification data entered, this can be exported to a log file that can be opened using software such as
Notepad or Excel. Click the “Save” Button at the bottom of this tab and the verification data will be saved to a log
inside the program. If “Auto Export Verification” is turned on, a .csv file will automatically be produced. If this setting
is not turned on, all verification data can be manual exported by navigating to File->Export->Verification Data.
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Example:

| SAEspec2597 - Notepad — O X

File Edit Format View Help

9/7/2022 10:52:14 AM

Operator: Tom Brady

Peening Time: 5.477

Location:,Test 1,Test 2,Test 3,Test 4
Target:,0.0065,0.0039,0.008,0.0054
Measured:,0.0066,0.004,0.008,0.0055

9/7/2022 10:53:18 AM

Operator: Dave Barkley

Peening Time: 5.477

Location:,Test 1,Test 2,Test 3,Test 4
Target:,0.0065,0.0039,0.008,0.0054
Measured:,0.0066,0.004,0.008,0.0055

9/9/2022 10:17:08 AM

Operator: Dave Barkley

Peening Time: 5

Location:,Test 1,Test 2,Test 3,Test 4
Target:,0.0064,0.0038,0.0079,0.0054
Measured:,0.0064,0.0055,0.0081,0.0031

Ln 22, Col1 100%  Windows (CRLF) UTF-8
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Saturation Report

PeenSolver Pro™ can output all data and curve to a simple PDF page that can be used for documentation purposes.
Navigate to File -> Export -> Saturation Report. The user will then be prompted to select a save location for the PDF.
An example Saturation Report can be found below, showing a report with two peening locations.

1011412022 1:48 PM Untitied Page 102 1071412022 1:48 PM Untitied Page 2012

Electronics Inc. Saturation Report Electronics Inc.

5 Saturation Report
Shot Peening Control Shot Peening Control ¥
Process Settings Process Settings
Name: Untitled Date: 10/14/2022 Name: Untitled Date: 10/14/2022
Operator: Ken Derucki Operator: Ken Derucki
Comments: Testing Comments: Testing
Peening Method: Conventional Strip Type: A Peening Method: Conventional Strip Type: A
Curve Type: AUTO (EXP2P) Control Type: Time (s) Curve Type: AUTO (EXP2P) Control Type: Time (s)
Shot Type: S230 Air Pressure: 65 psi Shot Type: S230 Air Pressure: 65 psi
Flow Rate: 10 Ib/min Speed: 10 rpm Flow Rate: 10 Ib/min Speed: 10 pm
Blasting Angle: 90 deg Nozzle Size: 025" Blasting Angle: 90 deg Nozzle Size: 0.25"
Nozzle Distance: 8" Flapper Speed: 5500 Nozzle Distance: 8" Flapper Speed: 5500
Top Bottom
Strip # 1 2 3 2 Strip # 1 2 3 4 5
Time (s) > 2 8 6 Time (s) 2 4 8 16 32
Arc Height (in) 0.0069 00078 0.0084 0.0086 Arc Height (in) [ 0.0079 0.0086 0.0094 0.0096 001
Curve Error (%) 168 366 0.03 2927 Curve Error (%) 0.16 -0.72 13 112 0.38
Curve Type: EXP2P Saturation Intensity (in): 0.0076 Curve Type: EXP3P Saturation Intensity (in): 0.0079
Average Error (%): 1.91 Saturation Time (s): 2.8 A\{erage Ervor (%): 0.74 " Saturation Tlme (s): 2
Warning: Type 2 Curve — Shortest peened time is longer than T. Intensity changed to first peened strip’s
arc height
. Saturation Curve
Saturation Curve
0,01 %
— = 1 ke K
] *
£ 7 -
£ =
£0.005 10,005 |
z ©
3 1 > ]
=~ 4
il L o e IO A e e ML Ao e e s e e LA B e e e e
O e e e e e A e L B e e e e e o T B e B 0 5 10 15 20 25 30 35
0 2 4 6 8 10 12 14 16 Time (s)
Time (s)
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Contacting Electronics Inc.

Electronics Inc.
56790 Magnetic Drive Mishawaka, Indiana 46545 USA

Telephone
1-800-832-5653 (Toll-free in USA and Canada) or (574) 256-5001

Fax
(574) 256-5222

Website
www.electronics-inc.com
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